PROLITH v11.0

Getting Started Guide

# Table of Contents

**Introduction** ................................................................. 1  
  About This Guide .......................................................... 1  
  Contacting Technical Support ........................................... 2  
  System Requirements ....................................................... 4  

**Installing a Single User License of PROLITH** ....................... 6  

**Installing a Concurrent User License of PROLITH** ............... 10  
  Configuring the Windows Licensing Server .......................... 11  
  Configuring the Linux Licensing Server ............................. 21  
  Installing PROLITH ......................................................... 27  

**Index** .................................................................................. 30
Introduction

About This Guide

This guide contains the following information:

• Instructions for installing a single user license of PROLITH on
  your computer or for upgrading the single user license version of
  PROLITH on your computer to 11.0

• Instructions for configuring a Windows licensing server or a Linux
  licensing server for a concurrent user license installation of
  PROLITH

• Instructions for installing a concurrent user license of PROLITH
  on a client from the web or for upgrading the concurrent user
  license version of PROLITH on a client to 11.0 from the web
Contacting Technical Support

You can contact us using any of the following methods:

If You are in the U.S., Singapore, Malaysia, or China

Address:  
KLA-Tencor, Inc.  
8834 N. Capital of Texas Highway  
Suite 301  
Austin, Texas 78759

Telephone:  512-231-4200

Form to Submit PROLITH Questions:
http://www.kla-tencor.com/products/support_request.html

If You are in Taiwan

Address:  
Grand Technology, Inc.  
11F-1 No. 440 Chung Hsiao Rd.  
Hsin-Chu, Taiwan

Telephone:  3 562-2675

E-mail address: Grandti@ms9.hinet.net

If You are in Japan

Address:  
Litho Tech Japan Corp.  
2-6-6-201 Namiki,  
Kawaguchi-Saitama  
332-0034 Japan

Telephone:  +81 (48) 258-6775

E-mail address: tajima@LTJ.co.jp or tech-support@LTJ.co.jp

If You are in Korea

Contact:  
Kenny (Keunyoung) Kim  
International Technology Alliances, Inc.

Telephone:  408-621-3492 or 82-10-3394-2532 when in Korea

E-mail address: kenny.kim@itechall.com
If You are in Europe

Address: Hillelian Concepts, Inc.
         129 bis, rue de Tolbiac
         75013 Paris, France

Telephone: +33.1.44.24.00.00

E-mail address: all@hillelian.com
System Requirements

PROLITH Recommended System Requirements

For optimal performance, we recommend the following system configuration. If you do not meet the recommended requirements, you can still run PROLITH but your simulations will be slower.

- IBM PC-compatible computer with 2.0 gigahertz (GHz) or faster AMD Athlon 64 or with 2.0 GHz or faster Intel Core 2 microprocessor. We recommend a total of four cores. You can configure your computer as either a single four-core microprocessor or a dual-core dual microprocessor.
- Microsoft Windows XP (Professional or Home edition with Service Pack 2 or later), Windows Server 2003 (with Service Pack 1 or later), Windows XP 64 bit (with Service Pack 1 or later), or Windows Vista (Business or Ultimate edition).
- 2 gigabytes (GB) or more of RAM.
- 1 GB or more of disk space on the drive where you are installing PROLITH and 40 megabytes (MB) of additional disk space on the system drive (usually C).
- Super VGA (SVGA)-compatible graphics card with 1280 x 1024 resolution and True Color (32 bit).
- Microsoft Internet Explorer 6.0 or later.

Licensing Server Recommended System Requirements

You can place the licensing server on any standard computer. The licensing server does not require a fast microprocessor, a large amount of RAM, or a large amount of disk space. The operating system on the licensing server can be Windows, or Red Hat Enterprise Linux v3 or v4.

If you are configuring a licensing server cluster (a grouping in which two or three computers act collectively as a licensing server), the requirements are as follows:

- The computers in the cluster can contain a mixture of Windows and Linux operating systems.
- Supported number of computers in the cluster: 2 or 3
- Minimum number of computers in the cluster that you must start for the cluster to act as a licensing server: 2
System Requirements

- Minimum number of computers in the cluster that must be running for the cluster to act as a licensing server: 1. For example, if two of three computers in the cluster fail but the third computer is still running, clients can continue to check out licenses.

- If you manually stop the license manager service on any computer in the cluster, this stops the license manager service on every computer in the cluster. That means that clients can no longer check out licenses.

PROLITH Programming Interface Recommended System Requirements

We recommend the following configuration for using the PPI:

- To run the PPI from the Visual Basic environment, you must have one of the following: Microsoft Excel 2003 or later or Microsoft Visual Basic v6.0 or later.

  **NOTE:** Microsoft Excel embeds Visual Basic for Applications (VBA).

- To run the PPI from the MATLAB environment, you must have MATLAB v2007b or MATLAB v2008a.

  All PPI examples in the PROLITH Help were created using the latest version of MATLAB. Therefore, some of the MATLAB commands in the PPI examples might not work with older versions of MATLAB.
Installing a Single User License of PROLITH

This section describes how to install PROLITH if you bought a single user license and are either installing PROLITH for the first time or upgrading PROLITH. If you instead bought a concurrent user license, see “Installing a Concurrent User License of PROLITH” on page 10.

NOTE: If you are running Windows Vista, your security settings may require extra confirmation before performing some of the steps in this document. If prompted, click Allow or Continue.

Install PROLITH

This procedure covers downloading PROLITH and installing it.

NOTE: You must have local administrator privileges and a valid license file.

NOTE: You can leave an older version of PROLITH on your computer. You can use your PROLITH v11.0 license to run both the previous version of PROLITH and PROLITH v11.0.

2. Click Products.
3. In the RELATED PRODUCTS panel, click PROLITH.
4. If you have a password for the users-only site:
   a. Click Enter the Users Only Site.
   b. In the User name field, type your e-mail address.
   c. In the Password field, type the password you chose and then click OK.
   -or-
   If you do not have a password for the users-only site:
   a. At the bottom of the screen, click Request Access.
   b. In the Email field, type your e-mail address and then click Submit.
c. Enter your information in the fields on the screen, and then click Submit.

d. When you receive a “KLA-Tencor Users Only - Account Request Approved” e-mail from KLA-Tencor, click the first link in the e-mail.

e. In the Desired Password field, type the password you would like to use to get to the users-only site.

f. In the Verified Password field, retype the password.

g. Click Submit.


i. In the User name field, type your e-mail address.

j. In the Password field, type the password you chose and then click OK.

5. Click Downloads.

6. To submit a request to download the software:

   a. Click PROLITH v11.0.

   b. Enter information on the screen, and then click Submit.

   c. Verify your information, and then click Submit.

7. To obtain a PROLITH license:

   a. Click Products.

   b. In the RELATED PRODUCTS panel, click PROLITH.

   c. Click Enter the Users Only Site.

   d. Click Downloads.

   e. Click v8_Lmtools.exe.

   f. Save the file to your desktop.

   g. If you have a laptop, undock your computer or disconnect it from the network, and then restart your computer.

   h. On your desktop, double-click the v8_Lmtools icon.

   i. Click the System Settings tab.

   j. Click Save HOSTID Info to a File.

   k. Navigate to the location where you want to save the file.

   l. Type a name for the file, and then click Save.

   m. E-mail the file to Cynthia.Johnson@kla-tencor.com.
8. To download the software:
   a. When you receive a “KLA-Tencor Users Only - Download Authorization Approved” e-mail from KLA-Tencor, click the download link in the e-mail.
   b. Click **PROLITH v11.0**.
   c. Save the software to your desktop.

9. Save the license file (**PROLITH.lic**) that you received from KLA-Tencor onto your desktop.

10. On your desktop, double-click the **PROLITH_11_0_Install** icon.

11. If you have an earlier version of PROLITH on your computer that you are required to uninstall, the instructions on the screen will ask whether you want to remove the older version. If you receive such a message, click **Yes**.

12. Follow the instructions on the screen.

**(Optional) Update PPI Functionality in VBA**

If you plan to use or have been using the PPI with Visual Basic for Applications (VBA), to update your reference to the **Prolith.exe** file, do the following in each file that contains a PPI macro:

1. Start the application you used to create the file.

2. To start the Visual Basic Editor, in the application, select **Tools -> Macro -> Visual Basic Editor**.

3. Select **Tools -> References**.

4. In the **Available References** list, look for a **Prolith** check box.
   - If you see the check box, proceed to step 6. If you do not see the check box, proceed to the next step.

5. To add the **Prolith** check box to the list:
   a. Click **Browse**.
   b. In the **Files of type** list, select **All Files**.
   c. Navigate to the **InstallPath\Prolith.exe** file, where **InstallPath** is the directory in which you installed PROLITH.
      - The default installation directory is **C:\Program Files\KLA-Tencor\PROLITH 11.0**.

6. In the **Available References** list, select the **Prolith** check box and then click **OK**.
(Optional) Update PPI Functionality in MATLAB

If you plan to use or have been using the PPI with MATLAB, to add or update the PPI functionality in MATLAB:

1. In MATLAB, select **File -> Set Path**.
2. Click **Add Folder**.
3. Navigate to the `InstallPath\MATLABPPI` directory, where `InstallPath` is the directory in which you installed PROLITH.
4. Click **Save**.
Installing a Concurrent User License of PROLITH

This section describes how to install PROLITH if you bought a concurrent user license and are either installing PROLITH for the first time or upgrading PROLITH. If you instead bought a single user license, see “Installing a Single User License of PROLITH” on page 6.

To install a concurrent user license of PROLITH, you must:

1. Install the license manager on a Windows server and create or update the license file on the server. See “Configuring the Windows Licensing Server” on page 11.
   -or-
   Install the license manager on a Linux server and create or update the license file on the server. See “Configuring the Linux Licensing Server” on page 21.

2. Install PROLITH on clients from the web. See “Installing PROLITH” on page 27.
Configuring the Windows Licensing Server

This section describes how to: 1) install the license manager on a Windows server and 2) create the license file on the server if you bought a concurrent user license and are either installing PROLITH for the first time or upgrading PROLITH. If you instead bought a single user license, see “Installing a Single User License of PROLITH” on page 6. If you are instead using a Linux server, see “Configuring the Linux Licensing Server” on page 21.

NOTE: You must set up your network so that client computers can see the licensing server.

NOTE: You must have local administrator privileges.

NOTE: You must have a valid license file.

Verify Whether You Must Install the License Manager on the Licensing Server

If your computer does not contain a FINLE License Manager or if the version of the FINLE License Manager is older than 11.4, you must install the latest version of the license manager. To verify whether you must install the new license manager:

1. Navigate to the C:\Program Files\KLA-Tencor directory.
2. If you do not see the FINLE License Manager folder, follow the remaining procedures in this section, beginning with “Install the License Manager on the Licensing Server” on page 12.
   -or-
   If you see the FINLE License Manager folder, open it.
3. Right-click on the lmgrd file, and then select Properties.
4. In Windows Vista, click the Details tab.
   -or-
   In Windows XP or Windows Server 2003, click the Version tab.
5. If the version listed next to File version is 11.4 or higher, skip to “Verify Whether You Must Create or Update the License File on the Licensing Server” on page 16.
   -or-
If the version listed next to File version is lower than 11.4, follow the remaining procedures in this section, beginning with “Install the License Manager on the Licensing Server” on page 12.

Install the License Manager on the Licensing Server

If you determined in "Verify Whether You Must Install the License Manager on the Licensing Server" on page 11 that the licensing server does not contain the FINLE License Manager or that the version of the license manager is older than 11.4, you must install the license manager on the server. This procedure covers downloading the license manager and installing it on the server.

2. Click Products.
3. In the RELATED PRODUCTS panel, click PROLITH.
4. If you have a password for the users-only site:
   a. Click Enter the Users Only Site.
   b. In the User name field, type your e-mail address.
   c. In the Password field, type the password you chose and then click OK.
   -or-
   If you do not have a password for the users-only site:
   a. At the bottom of the screen, click Request Access.
   b. In the Email field, type your e-mail address and then click Submit.
   c. Enter your information in the fields on the screen, and then click Submit.
   d. When you receive a “KLA-Tencor Users Only - Account Request Approved” e-mail from KLA-Tencor, click the first link in the e-mail.
   e. In the Desired Password field, type the password you would like to use to get to the users-only site.
   f. In the Verified Password field, retype the password.
   g. Click Submit.
   i. In the User name field, type your e-mail address.
Configuring the Windows Licensing Server

j. In the **Password** field, type the password you chose and then click **OK**.

5. Click **Downloads**.

6. To download the FINLE License Manager software:
   a. Click **FINLE License Manager (Windows)**.
   b. Save the software to the desktop on the licensing server.

7. On the desktop, double-click the **FINLE_License_Manager_v11.4** icon.

8. Follow the instructions on the screen.

**Configure the Windows Firewall**

If you have turned on the Windows firewall, you must configure it by following the steps below. This allows clients to access the licensing server.

This procedure only covers configuring the Windows firewall. If you are using a firewall other than the Windows firewall, you must set up your own process-based exception list to allow the finle.exe and lmgrd.exe processes to open ports in your firewall. Use this procedure as a guide.

1. To open the Windows Firewall, navigate to the **Control Panel**.
2. In the address bar at the top of the window, type:
   
   `C:\WINDOWS\System32\Firewall.cpl`

3. If you are running Windows Vista, click the **Change settings** link.
4. Click the **Exceptions** tab.
5. To allow clients to access the licensing server:
   a. Click **Add Program**.
   b. Click **Browse**.
   c. Navigate to the **lmgrd.exe** file, and then click **Open**.

   This file should be in the C:\Program Files\KLA-Tencor\FINLE License Manager directory.
   d. Click **OK**.
   e. Select **lmgrd**. (See Figure 1.)
f. Click **Add Program**.

g. Click **Browse**.

h. Navigate to the **finle.exe** file, and then click **Open**.

This file should be in the C:\Program Files\KLA-Tencor\FINLE License Manager directory.

i. Click **OK**.

j. Select **finle.exe**. (See Figure 2.)
Configuring the Windows Licensing Server

Obtain a PROLITH License

For each release of PROLITH, you need a new license file. You must perform this procedure on the licensing server.

2. Click Products.
3. In the RELATED PRODUCTS panel, click PROLITH.
4. Click Enter the Users Only Site.
5. In the User name field, type your e-mail address.
6. In the Password field, type the password you chose and then click OK.
7. Click Downloads.
8. Click v8_lmtools.exe.
9. Save the file to your desktop.
10. If you have a laptop, undock your computer or disconnect it from the network, and then restart your computer.
11. On your desktop, double-click the \v8_lntools\ icon.
12. Click the System Settings tab.
13. Click Save HOSTID Info to a File.
14. Navigate to the location where you want to save the file.
15. Type a name for the file, and then click Save.
16. Attach the file to an e-mail message, and send it to Cynthia.Johnson@kla-tencor.com.

Verify Whether You Must Create or Update the License File on the Licensing Server

If the licensing server does not contain a licenses.dat file, you must create the file. If the server contains a licenses.dat file, you must update the file. This file may exist if you have other KLA-Tencor software or if others’ software uses it.

1. Navigate to the C:\Program Files\KLA-Tencor\Licenses directory.
2. If you see a licenses.dat file, follow “Update the License File on the Licensing Server” on page 17.
   -or-
   If you do not see a licenses.dat file, follow “Create the License File on the Licensing Server” on page 16.

Create the License File on the Licensing Server

If you determined in “Verify Whether You Must Create or Update the License File on the Licensing Server” on page 16 that the licensing server does not contain a license file, you must create a license file on the server. You need a license file to run PROLITH. The FINLE License Manager reads this file to verify that you have a valid concurrent user license for PROLITH v11.0.

1. Copy the PROLITH.lic file from the e-mail you received from KLA-Tencor, and paste it on the server in the C:\Program Files\KLA-Tencor\Licenses directory.
2. Open the PROLITH.lic file in any text editor (for example,
3. On line 1 in the file, change host_name to your server’s computer name.

- or -

If you are setting up a cluster licensing server, change host_name on each line that begins with “SERVER” to the name of each computer in the cluster.

NOTE: If you do not know the name of your server, ask your company’s I.T. professional.

4. Save the file, and close the text editor.

5. Copy this file, and paste it in the same directory.

6. Rename the copy of the file to licenses.dat.

7. Skip to “Start the License Manager on the Licensing Server” on page 18.

**Update the License File on the Licensing Server**

If you determined in “Verify Whether You Must Create or Update the License File on the Licensing Server” on page 16 that the licensing server contains a license file, you must update it. You need current license information in the license file to run PROLITH. The FINLE License Manager reads this file to verify that you have a valid concurrent user license for PROLITH v11.0.

1. In a text editor, open the PROLITH.lic file that you received in an e-mail from KLA-Tencor.

2. Copy the license information in the FEATURE section of the PROLITH.lic file. (That is, copy the line that begins with “FEATURE” and all the indented lines under it.)

3. Navigate to the C:\Program Files\KLA-Tencor\Licenses directory.

4. Open the licenses.dat file in any text editor (for example, Notepad).

5. In the licenses.dat file, paste the information from step 2 below the line that begins with “DAEMON FINLE”.

- or -

If you have a cluster licensing server, paste the information from step 2 below the line that begins with “VENDOR FINLE”.
Configuring the Windows Licensing Server

WARNING: During the paste, do not copy over any existing information in the licenses.dat file.

6. Save the file.
7. Close the file.

Start the License Manager on the Licensing Server

You must configure and start the license manager service before client computers can connect to the licensing server.

1. To open the FINLE License Manager, click start and then select All Programs -> KLA-Tencor -> FINLE License Manager -> FINLE License Manager.
2. Click the Service/License File tab. (See Figure 3.)

![Figure 3: LMTOOLS Service/License File tab](image)

3. Select FINLE License Manager.
4. Click the Config Services tab. (See Figure 4.)
5. Click **Browse** next to Path to the license file.

6. Navigate to the `C:\Program Files\KLA-Tencor\Licenses\licenses.dat` file, and then click **Open**.

7. Select the **Use Services** check box.

8. Select the **Start Server at Power Up** check box.

   Selecting this check box means the license manager service will automatically start when you restart your computer.

9. Click **Save Service**.

10. Click **Yes**.

11. Click the **Start/Stop/Reread** tab. (See Figure 5.)
Configuring the Windows Licensing Server

Figure 5: LMTOOLS Start/Stop/Reread tab

12. Click Start Server.

13. Close the LMTOOLS window.
Configuring the Linux Licensing Server

This section describes how to: 1) install the license manager on a Linux server and 2) create the license file on the server if you bought a concurrent user license and are either installing PROLITH for the first time or upgrading PROLITH. If you instead bought a single user license, see “Installing a Single User License of PROLITH” on page 6. If you are instead using a Windows server, see “Configuring the Windows Licensing Server” on page 11.

NOTE: You must set up your network so that client computers can see the licensing server.

NOTE: To perform the procedures in this section, you must be logged in as root.

NOTE: You must have a valid license file.

Verify Whether You Must Install the License Manager on the Licensing Server

If your computer does not contain a FINLE License Manager or if the version of the FINLE License Manager is older than 11.4, you must install the latest version of the license manager. To verify whether you must install the new license manager:

1. Start a shell, and then type the following:
   
   `rpm -q finlelicensemanager`

2. If you see “package finlelicensemanager is not installed”, follow the remaining procedures in this section, beginning with “Install the License Manager on the Licensing Server” on page 21.

3. If the version listed next to `finlelicensemanager` is 11.4 or higher, skip to “Verify Whether You Must Create or Update the License File on the Licensing Server” on page 24.

   -or-

   If the version listed next to `finlelicensemanager` is lower than 11.4, follow the remaining procedures in this section, beginning with “Install the License Manager on the Licensing Server” on page 21.

Install the License Manager on the Licensing Server

If you determined in "Verify Whether You Must Install the License Manager on the Licensing Server" on page 21 that the licensing server
does not contain the FINLE License Manager or that the version of the license manager is older than 11.4, you must install the license manager on the server. This procedure covers downloading the license manager and installing it on the server.

2. Click **Products**.
3. In the **RELATED PRODUCTS** panel, click **PROLITH**.
4. If you have a password for the users-only site:
   a. Click **Enter the Users Only Site**.
   b. In the **User name** field, type your e-mail address.
   c. In the **Password** field, type the password you chose and then click **OK**.

   -or-

   If you do not have a password for the users-only site:
   a. At the bottom of the screen, click **Request Access**.
   b. In the **Email** field, type your e-mail address and then click **Submit**.
   c. Enter your information in the fields on the screen, and then click **Submit**.
   d. When you receive a “KLA-Tencor Users Only - Account Request Approved” e-mail from KLA-Tencor, click the first link in the e-mail.
   e. In the **Desired Password** field, type the password you would like to use to get to the users-only site.
   f. In the **Verified Password** field, retype the password.
   g. Click **Submit**.
   i. In the **User name** field, type your e-mail address.
   j. In the **Password** field, type the password you chose and then click **OK**.

5. Click **Downloads**.
6. To download the FINLE License Manager software:
   a. Click **FINLE License Manager (Linux)**.
   b. Save the software to the location of your choice on the licensing server.
7. If a shell is not started, start a shell.

8. To change to the directory where you saved the FINLE License Manager, type the following:

   \texttt{cd DirectoryName}

9. To install the FINLE License Manager software, type the following:

   \texttt{rpm -i finlelicensemanager-11.4-1.x86_64.rpm}

**Configure the Firewall**

If you have turned on a firewall, you must configure it to allow clients to access the licensing server. You must open a port in your firewall for the FINLE daemon.

**Obtain a PROLITH License**

For each release of PROLITH, you need a new license file.

1. Go to \url{http://www.kla-tencor.com}.

2. Click \textbf{Products}.

3. In the \textbf{RELATED PRODUCTS} panel, click \textbf{PROLITH}.

4. Click \textbf{Enter the Users Only Site}.

5. In the \textbf{User name} field, type your e-mail address.

6. In the \textbf{Password} field, type the password you chose and then click \textbf{OK}.

7. Click \textbf{Downloads}.

8. Click \textbf{Installation Utility}.

9. Click \textbf{lmhostID}.

10. Save the file to the location of your choice on the licensing server.

11. On the licensing server:

   a. Unzip the \texttt{lmhostID} file you downloaded into the location of your choice.

   b. Start a shell.

   c. To change to the directory where you unzipped the \texttt{lmhostID} file, type the following:

      \texttt{cd DirectoryName}

   d. Type the following:
12. Copy the following line:

   ```
   The FLEXnet host ID of this machine is “...”
   ```

13. Paste the line into an e-mail message, and send it to Cynthia.Johnson@kla-tencor.com.

### Verify Whether You Must Create or Update the License File on the Licensing Server

If the licensing server does not contain a `licenses.dat` file, you must create the file. If the server contains a `licenses.dat` file, you must update the file. This file may exist if you have other KLA-Tencor software or if others’ software uses it.

1. Navigate to the `/etc/flexlm/finle` directory.

2. If you see a `licenses.dat` file, follow “Update the License File on the Licensing Server” on page 25.

   -or-

   If you do not see a `licenses.dat` file, follow “Create the License File on the Licensing Server” on page 24.

### Create the License File on the Licensing Server

If you determined in “Verify Whether You Must Create or Update the License File on the Licensing Server” on page 24 that the licensing server does not contain a license file, you must create a license file on the server. You need a license file to run PROLITH. The FINLE License Manager reads this file to verify that you have a valid concurrent user license for PROLITH v11.0.

1. Save the `PROLITH.lic` file from the e-mail you received from KLA-Tencor to the `/etc/flexlm/finle` directory on the server.

2. Open the `PROLITH.lic` file in any text editor.

3. On line 1 in the file, change `host_name` to your server’s computer name.

   -or-
Configuring the Linux Licensing Server

If you are setting up a cluster licensing server, change `host_name` on each line that begins with “SERVER” to the name of each computer in the cluster.

**NOTE:** If you do not know the name of your server, ask your company’s I.T. professional.

4. Save the file, and close the text editor.
5. Make a copy of this file in the same directory, and name it `licenses.dat`.

Update the License File on the Licensing Server

If you determined in “Verify Whether You Must Create or Update the License File on the Licensing Server” on page 24 that the licensing server contains a license file, you must update it. You need current license information in the license file to run PROLITH. The FINLE License Manager reads this file to verify that you have a valid concurrent user license for PROLITH v11.0.

1. In a text editor, open the `PROLITH.lic` file that you received in an e-mail from KLA-Tencor.
2. Copy the license information in the FEATURE section of the `PROLITH.lic` file. (That is, copy the line that begins with “FEATURE” and all the indented lines under it.)
3. Navigate to the `/etc/flexlm/finle` directory.
4. Open the `licenses.dat` file in any text editor.
5. In the `licenses.dat` file, paste the information from step 2 below the line that begins with “DAEMON FINLE”.
   -or-
   If you have a cluster licensing server, paste the information from step 2 below the line that begins with “VENDOR FINLE”.

**WARNING:** During the paste, do not copy over any existing information in the `licenses.dat` file.

6. Save the file.
7. Close the file.
Start the License Manager on the Licensing Server

You must configure and start the license manager service before client computers can connect to the licensing server.

1. If a shell is not started, start a shell.
2. To start the FINLE License Manager software, type the following:
   
   /etc/rc.d/init.d/finlelicensemanager start

3. (Optional) To verify that the FINLE License Manager software is running, type the following:
   
   /etc/rc.d/init.d/finlelicensemanager status
Installing PROLITH

This section describes how to install PROLITH on clients from the web if you bought a concurrent user license and are either installing PROLITH for the first time or upgrading PROLITH. If you instead bought a single user license, see “Installing a Single User License of PROLITH” on page 6.

NOTE: If you are running Windows Vista, your security settings may require extra confirmation before performing some of the steps in this document. If prompted, click Allow or Continue.

Install PROLITH

This procedure covers downloading PROLITH and installing it. Before you can initially install or upgrade PROLITH on a client, you must have configured the licensing server. See “Configuring the Windows Licensing Server” on page 11 or “Configuring the Linux Licensing Server” on page 21.

NOTE: You must have local administrator privileges and a valid license file.

NOTE: You can leave an older version of PROLITH on your computer. You can use your PROLITH v11.0 license to run both the previous version of PROLITH and PROLITH v11.0.

2. Click Products.
3. In the RELATED PRODUCTS panel, click PROLITH.
4. If you have a password for the-only site:
   a. Click Enter the Users Only Site.
   b. In the User name field, type your e-mail address.
   c. In the Password field, type the password you chose and then click OK.
   -or-
   If you do not have a password for the users-only site:
   a. At the bottom of the screen, click Request Access.
   b. In the Email field, type your e-mail address and then click Submit.
c. Enter your information in the fields on the screen, and then click Submit.

d. When you receive a “KLA-Tencor Users Only - Account Request Approved” e-mail from KLA-Tencor, click the first link in the e-mail.

e. In the Desired Password field, type the password you would like to use to get to the users-only site.

f. In the Verified Password field, retype the password.

g. Click Submit.


i. In the User name field, type your e-mail address.

j. In the Password field, type the password you chose and then click OK.

5. Click Downloads.

6. To submit a request to download the software:

   a. Click PROLITH v11.0.

   b. Enter information on the screen, and then click Submit.

   c. Verify your information, and then click Submit.

7. To download the software:

   a. When you receive a “KLA-Tencor Users Only - Download Authorization Approved” e-mail from KLA-Tencor, click the download link in the e-mail.

   b. Click PROLITH v11.0.

   c. Save the software to your desktop.

8. On your desktop, double-click the PROLITH_11_0_Install icon.

9. If you have an earlier version of PROLITH on your computer that you are required to uninstall, the instructions on the screen will ask whether you want to remove the older version. If you receive such a message, click Yes.

10. Follow the instructions on the screen.

(Optional) Update PPI Functionality in VBA

If you plan to use or have been using the PPI with Visual Basic for Applications (VBA), to update your reference to the Prolith.exe file, do the following in each file that contains a PPI macro:
1. Start the application you used to create the file.
2. To start the Visual Basic Editor, in the application, select **Tools -> Macro -> Visual Basic Editor**.
3. Select **Tools -> References**.
4. In the **Available References** list, look for a **Prolith** check box.
   - If you see the check box, proceed to step 6. If you do not see the check box, proceed to the next step.
5. To add the **Prolith** check box to the list:
   a. Click **Browse**.
   b. In the **Files of type** list, select **All Files**.
   c. Navigate to the `InstallPath\Prolith.exe` file, where `InstallPath` is the directory in which you installed PROLITH.
      - The default installation directory is `C:\Program Files\KLA-Tencor\PROLITH 11.0`.
6. In the **Available References** list, select the **Prolith** check box and then click **OK**.

**(Optional) Update PPI Functionality in MATLAB**

If you plan to use or have been using the PPI with MATLAB, to add or update the PPI functionality in MATLAB:

1. In MATLAB, select **File -> Set Path**.
2. Click **Add Folder**.
3. Navigate to the `InstallPath\MATLABPPI` directory, where `InstallPath` is the directory in which you installed PROLITH.
4. Click **Save**.
Index

C
client installation 27
cluster requirements 4
color palette requirements 4
concurrent user license installation 10
D
disk space requirements 4
F
FINLE License Manager
installing on servers
   Linux 21
   Windows 12
starting on servers
   Linux 26
   Windows 18
verifying whether to install on servers
   Linux 21
   Windows 11
firewalls, configuring
   Linux 23
   Windows 13
G
graphic requirements 4
H
hard disk space requirements 4
hardware requirements 4
I
installation, PROLITH
   about 1
   of concurrent user licenses 10
   of single user licenses 6
K
KLA-Tencor PROLITH support 2
L
license files
   creating on servers
      Linux 24
   obtaining
      concurrent user 15, 23
      single user 7
   updating on servers
      Linux 25
      Windows 17
   verifying whether to install on servers
      Linux 21
      Windows 11
license managers
   installing on servers
      Linux 21
      Windows 12
   starting on servers
      Linux 26
      Windows 18
   verifying whether to install on servers
      Linux 21
      Windows 11
licenses.dat
   creating on servers
      Linux 24
      Windows 16
   updating on servers
      Linux 25
      Windows 17
   verifying whether to create or update on servers
      Linux 24
      on Windows servers 16
licensing servers
   configuration
      Linux 21
      Windows 11
   system requirements 4
Linux firewall, configuring 23
N
network license installation. See concurrent user license installation
network servers
  configuration
    Linux 21
    Windows 11
  system requirements 4
O
operating system requirements 4
P
PPI system requirements 5
PROLITH Getting Started Guide, about 1
PROLITH Programming Interface system requirements 5
R
requirements, system 4
resolution requirements 4
S
servers
  configuration
    Linux 21
    Windows 11
  system requirements 4
single user license installation 6
software requirements 4
stand-alone license installation. See single user license installation
support, PROLITH 2
system requirements 4
T
technical support, PROLITH 2
third-party software 4
U
upgrading PROLITH
  concurrent user licenses 10
  single user licenses 6
W
web installation
  for concurrent user licenses 27
  for single user licenses 6
Windows firewall, configuring 13